新闻资讯

针对Pve8新版本无法使用SSH2的问题
2023-07-12 01:26    浏览:3154次

本问题原因是
Linux 2023禁用了原来默认的ssh-rsa host key算法,改为了sh-ed25519和ecdsa-sha2-nistp256两种host key算法,然而,令人遗憾的时,多数SSH客户端并不支持这两种host key算法,所以会报上面的错误
所以此处的解决方案是在ssh配置添加如下文件

现象和原因:

 

openssh升级新版本后,旧的算法不再支持,导致CRT工具远程连接的时候连接不上

 

(旧的客户端不能连接新的服务端)

 

 

解决办法:

 

在ssh服务端配置添加配置如下:

 

#添加支持的加密算法
KexAlgorithms diffie-hellman-group1-sha1,diffie-hellman-group14-sha1,diffie-hellman-group-exchange-sha1,diffie-hellman-group-exchange-sha256,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group1-sha1,curve25519-sha256@libssh.org
 
#添加ssh-rsa算法
HostKeyAlgorithms +ssh-rsa



保存配置然后重启ssh服务即可

service sshd restart


为个人、中小IDC运营商、企业云平台的软硬一体化交付,在计算、存储、网络资源的融合之上实现简单上云!